net-im/deepin-wine-wecom: new package, add 4.1.6.6017
[gentoo-zh.git] / app-backup / btrfs-assistant / btrfs-assistant-1.8.ebuild
blobc86eaa0625a11793a9bdb0e5efc6cadc42ae9c7d
1 #Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit xdg cmake optfeature
8 SRC_URI="https://gitlab.com/btrfs-assistant/btrfs-assistant/-/archive/${PV}/${P}.tar.bz2"
9 KEYWORDS="~amd64 ~x86"
11 DESCRIPTION="A GUI management tool to make managing a Btrfs filesystem easier."
12 HOMEPAGE="https://gitlab.com/btrfs-assistant/btrfs-assistant"
14 LICENSE="GPL-3"
15 SLOT="0"
16 RESTRICT="mirror"
18 DEPEND="
19 dev-qt/qtcore:5
20 dev-qt/qtsvg:5
22 BDEPEND="${DEPEND}"
23 RDEPEND="
24 media-fonts/noto
25 sys-auth/polkit
26 sys-fs/btrfs-progs
27 ${DEPEND}
30 pkg_postinst() {
31 xdg_pkg_postinst
32 optfeature "auto snapshot" app-backup/snapper
33 optfeature "auto balance and defrag" sys-fs/btrfsmaintenance