1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit git-r3 go-module
8 DESCRIPTION
="GeoIP generator for V2Ray."
9 HOMEPAGE
="https://github.com/v2fly/geoip http://www.maxmind.com/"
10 EGIT_REPO_URI
="https://github.com/v2fly/geoip.git"
12 LICENSE
="CC-BY-SA-4.0"
17 BDEPEND
=">=dev-lang/go-1.16:="
21 #TODO: Looking for a more elegant way to download deps
22 export GOPROXY
="https://goproxy.cn,direct" || die
27 go build
-v -work -o ${PN} -trimpath .
/main.go || die
36 if [[ -z ${REPLACING_VERSIONS} ]]; then
40 elog
"to check the usage."
42 elog
"The original data files can be downloaded from:"
43 elog
"https://dev.maxmind.com/geoip/geoip2/geolite2/"
44 elog
"You need to sign up a maxmind account."