net-im/deepin-wine-wecom: new package, add 4.1.6.6017
[gentoo-zh.git] / net-im / dingtalk / dingtalk-1.7.0.30424.ebuild
blob31c0992afb2b8ecaa58c531fc5e59200c7968ad1
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PGK_NAME="com.alibabainc.dingtalk"
7 inherit desktop unpacker xdg
9 DESCRIPTION="Communication platform that supports video and audio conferencing"
10 HOMEPAGE="https://gov.dingtalk.com"
11 SRC_URI="https://dtapp-pub.dingtalk.com/dingtalk-desktop/xc_dingtalk_update/linux_deb/Release/com.alibabainc.${PN}_${PV}_amd64.deb"
13 LICENSE="all-rights-reserved"
14 SLOT="0"
15 KEYWORDS="-* ~amd64"
17 RESTRICT="strip mirror bindist"
19 RDEPEND="
20 dev-libs/libthai
21 dev-qt/qtgui
22 media-libs/tiff-compat:4
23 media-sound/pulseaudio
24 media-video/rtmpdump
25 net-misc/curl
26 net-nds/openldap
27 sys-libs/glibc
28 sys-libs/zlib
29 sys-process/procps
30 x11-libs/gtk+:2
31 x11-libs/gtk+:3
32 x11-libs/libXScrnSaver
35 DEPEND="${RDEPEND}"
37 BDEPEND="dev-util/patchelf"
39 S=${WORKDIR}
41 QA_PREBUILT="*"
43 src_install() {
44 # Install scalable icon
45 doicon -s scalable "${FILESDIR}"/dingtalk.svg
46 # Remove the libraries that break compatibility in modern systems
47 # Dingtalk will use the system libs instead
48 MY_VERSION=$(cat "${S}"/opt/apps/"${MY_PGK_NAME}"/files/version)
49 # Use system stdc++
50 rm -f "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libstdc++* || die
51 # Use system glibc
52 rm -f "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libm.so* || die
53 # Use system zlib
54 rm -f "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libz* || die
55 # Use system libcurl, fix preserved depend problem
56 rm -f "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libcurl.so* || die
57 # use system freetype, fix undefined symbol: FT_Get_Color_Glyph_Layer
58 rm -rf "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}"/libfreetype.so* || die
60 # Set RPATH for preserve-libs handling
61 pushd "${S}"/opt/apps/"${MY_PGK_NAME}"/files/"${MY_VERSION}" || die
62 local x
63 for x in $(find) ; do
64 # Use \x7fELF header to separate ELF executables and libraries
65 [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
66 local RPATH_ROOT="/opt/apps/${MY_PGK_NAME}/files/${MY_VERSION}"
67 patchelf --set-rpath "${RPATH_ROOT}/:${RPATH_ROOT}/swiftshader/:${RPATH_ROOT}/platforminputcontexts/:${RPATH_ROOT}/imageformats/" "${x}" || \
68 die "patchelf failed on ${x}"
69 done
70 popd || die
71 # fix ldd pattern error
72 sed -i 's/libc_version=.*/libc_version=`ldd --version | grep ldd | rev | cut -d" " -f1 | rev`/g' "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh || die
73 # Fix fcitx5
74 sed -i "s/export XMODIFIERS/#export XMODIFIERS/g" "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh || die
75 sed -i "s/export QT_IM_MODULE/#export QT_IM_MODULE/g" "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh || die
77 cat >> "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh.head <<- EOF || die
78 #!/bin/sh
79 if [ -z "\${QT_IM_MODULE}" ]
80 then
81 if [ -n "\$(pidof fcitx5)" ]
82 then
83 export XMODIFIERS="@im=fcitx"
84 export QT_IM_MODULE=fcitx
85 elif [ -n "\$(pidof ibus-daemon)" ]
86 then
87 export XMODIFIERS="@im=ibus"
88 export QT_IM_MODULE=ibus
89 elif [ -n "\$(pidof fcitx)" ]
90 then
91 export XMODIFIERS="@im=fcitx"
92 export QT_IM_MODULE=fcitx
95 EOF
97 cat "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh.head "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh > "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh.new || die
98 cat "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh.new > "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh || die
99 rm "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh.head "${S}"/opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh.new || die
101 # Add dingtalk command
102 mkdir -p "${S}"/usr/bin/ || die
103 ln -s /opt/apps/"${MY_PGK_NAME}"/files/Elevator.sh "${S}"/usr/bin/dingtalk || die
105 # Fix file path and desktop files
106 sed -E -i 's/^Icon=.*$/Icon=dingtalk/g' "${S}"/opt/apps/"${MY_PGK_NAME}"/entries/applications/*.desktop || die
108 mkdir -p usr/share/applications || die
109 mv "${S}"/opt/apps/"${MY_PGK_NAME}"/entries/applications/"${MY_PGK_NAME}".desktop usr/share/applications/ || die
111 # Install package and fix permissions
112 insinto /opt/apps
113 doins -r opt/apps/${MY_PGK_NAME}
114 insinto /usr
115 doins -r usr/*
117 pushd "${S}" || die
118 for x in $(find "opt/apps/${MY_PGK_NAME}") ; do
119 # Fix shell script permissions
120 [[ "${x: -3}" == ".sh" ]] && fperms 0755 "/${x}"
121 # Use \x7fELF header to separate ELF executables and libraries
122 [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] && fperms 0755 "/${x}"
123 done
124 popd || die