net-im/deepin-wine-wecom: new package, add 4.1.6.6017
[gentoo-zh.git] / x11-terms / wezterm-bin / wezterm-bin-20230712.ebuild
blobe266c62819f165f8d45e4dd396961ea7d2501928
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit xdg
8 MY_R="072601-f4abf8fd"
9 MY_PV="${PV}-${MY_R}"
10 MY_PN="${PN/-bin/}"
11 MY_P="${MY_PN}-${MY_PV}"
13 DESCRIPTION="A terminal emulator and multiplexer implemented in Rust"
14 HOMEPAGE="https://wezfurlong.org/wezterm"
16 SRC_URI="https://github.com/wez/wezterm/releases/download/${MY_PV}/${MY_PN}-${MY_PV}.Ubuntu20.04.tar.xz"
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="-* ~amd64"
22 IUSE="wayland +X"
23 REQUIRED_USE="|| ( wayland X )"
25 RESTRICT="mirror"
27 DEPEND=""
28 RDEPEND="${DEPEND}
29 sys-apps/dbus
30 >=media-libs/fontconfig-2.12
31 >=dev-libs/openssl-1.1
32 wayland? (
33 dev-libs/wayland
34 dev-libs/wayland-protocols
36 X? (
37 >=x11-libs/libX11-1.7.5
38 >=x11-libs/libxcb-1.8
39 >=x11-libs/xcb-util-0.4
40 >=x11-libs/xcb-util-wm-0.4.1
41 >=x11-libs/xcb-util-image-0.2.1
42 >=x11-libs/xcb-util-keysyms-0.4
43 x11-libs/libxkbcommon[X]
45 x11-themes/hicolor-icon-theme
48 QA_PREBUILT="*"
49 S="${WORKDIR}/${MY_PN}"
51 src_install() {
52 insinto /
53 doins -r etc usr
55 fperms 0755 /usr/bin/{open-wezterm-here,strip-ansi-escapes,wezterm,wezterm-gui,wezterm-mux-server}
56 fperms 0755 /etc/profile.d/${MY_PN}.sh