dev-vcs/sourcegit-bin: bump version to 8.38
[gentoo-zh.git] / dev-cpp / cppcoro / cppcoro-210105-r1.ebuild
blob9516f25d241a169018f4cbe140a5d38c3047e117
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake git-r3
8 DESCRIPTION="A library of C++ coroutine abstractions for the coroutines TS"
9 HOMEPAGE="https://github.com/Garcia6l20/cppcoro"
10 EGIT_REPO_URI="https://github.com/Garcia6l20/${PN}.git"
11 EGIT_COMMIT=e1d53e6
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64"
17 # currently, test is broken
18 IUSE="+shared"
19 RESTRICT="test"
21 PATCHES=(
22         "${FILESDIR}"/${PN}-ins-into-lib64.patch
23         "${FILESDIR}"/${PN}-include-utility.patch
26 src_configure() {
27         mycmakeargs=(
28                 -DBUILD_TESTING=OFF
29                 -DBUILD_SHARED_LIBS=$(usex shared ON OFF)
30         )
31         cmake_src_configure