app-editors/zed: add 0.148.0, drop 0.147.2
[gentoo-zh.git] / net-dns / dog / dog-0.1.0_p20211007.ebuild
blobb1407023bf29c5aeb7d3a21ee5006178f04bb76b
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
6 EAPI=8
8 CRATES="
9         addr2line@0.14.1
10         adler@1.0.2
11         ansi_term@0.12.1
12         atty@0.2.14
13         autocfg@1.0.1
14         backtrace@0.3.56
15         base64@0.13.0
16         bitflags@1.2.1
17         bumpalo@3.7.0
18         byteorder@1.4.3
19         cc@1.0.67
20         cfg-if@1.0.0
21         core-foundation-sys@0.8.2
22         core-foundation@0.9.1
23         ctor@0.1.20
24         datetime@0.5.1
25         diff@0.1.12
26         failure@0.1.8
27         failure_derive@0.1.8
28         foreign-types-shared@0.1.1
29         foreign-types@0.3.2
30         getopts@0.2.21
31         getrandom@0.2.2
32         gimli@0.23.0
33         hermit-abi@0.1.18
34         httparse@1.3.5
35         ipconfig@0.2.2
36         itoa@0.4.7
37         js-sys@0.3.49
38         json@0.12.4
39         lazy_static@1.4.0
40         libc@0.2.91
41         log@0.4.14
42         matches@0.1.8
43         miniz_oxide@0.4.4
44         native-tls@0.2.7
45         object@0.23.0
46         once_cell@1.7.2
47         openssl-probe@0.1.2
48         openssl-src@111.15.0+1.1.1k
49         openssl-sys@0.9.61
50         openssl@0.10.33
51         output_vt100@0.1.2
52         pkg-config@0.3.19
53         ppv-lite86@0.2.10
54         pretty_assertions@0.7.1
55         proc-macro2@1.0.24
56         quote@1.0.9
57         rand@0.8.3
58         rand_chacha@0.3.0
59         rand_core@0.6.2
60         rand_hc@0.3.0
61         redox_syscall@0.1.57
62         redox_syscall@0.2.5
63         remove_dir_all@0.5.3
64         ring@0.16.20
65         rustc-demangle@0.1.18
66         rustls@0.19.1
67         ryu@1.0.5
68         schannel@0.1.19
69         sct@0.6.1
70         security-framework-sys@2.2.0
71         security-framework@2.2.0
72         serde@1.0.125
73         serde_derive@1.0.125
74         serde_json@1.0.64
75         socket2@0.3.19
76         spin@0.5.2
77         syn@1.0.65
78         synstructure@0.12.4
79         tempfile@3.2.0
80         unic-char-property@0.9.0
81         unic-char-range@0.9.0
82         unic-common@0.9.0
83         unic-idna-mapping@0.9.0
84         unic-idna-punycode@0.9.0
85         unic-idna@0.9.0
86         unic-normal@0.9.0
87         unic-ucd-bidi@0.9.0
88         unic-ucd-hangul@0.9.0
89         unic-ucd-normal@0.9.0
90         unic-ucd-version@0.9.0
91         unicode-width@0.1.8
92         unicode-xid@0.2.1
93         untrusted@0.7.1
94         vcpkg@0.2.11
95         wasi@0.10.2+wasi-snapshot-preview1
96         wasm-bindgen-backend@0.2.72
97         wasm-bindgen-macro-support@0.2.72
98         wasm-bindgen-macro@0.2.72
99         wasm-bindgen-shared@0.2.72
100         wasm-bindgen@0.2.72
101         web-sys@0.3.49
102         webpki-roots@0.21.1
103         webpki@0.21.4
104         widestring@0.4.3
105         winapi-i686-pc-windows-gnu@0.4.0
106         winapi-x86_64-pc-windows-gnu@0.4.0
107         winapi@0.3.9
108         winreg@0.6.2
111 declare -A GIT_CRATES=(
112         [mutagen-core]='https://github.com/llogiq/mutagen;933bbaf4edaa22f6237b2201dff2940ff7f4193c;mutagen-%commit%/mutagen-core'
113         [mutagen-transform]='https://github.com/llogiq/mutagen;933bbaf4edaa22f6237b2201dff2940ff7f4193c;mutagen-%commit%/mutagen-transform'
114         [mutagen]='https://github.com/llogiq/mutagen;933bbaf4edaa22f6237b2201dff2940ff7f4193c;mutagen-%commit%/mutagen'
117 inherit cargo
119 DESCRIPTION="A command-line DNS client"
120 HOMEPAGE="https://dns.lookup.dog/"
121 EGIT_COMMIT="721440b12ef01a812abe5dc6ced69af6e221fad5"
122 SRC_URI="
123         https://github.com/ogham/dog/archive/${EGIT_COMMIT}.tar.gz -> ${P}.gh.tar.gz
124         ${CARGO_CRATE_URIS}
127 S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
129 LICENSE="EUPL-1.2"
130 # Dependent crate licenses
131 LICENSE+=" Apache-2.0 ISC MIT MPL-2.0"
132 SLOT="0"
133 KEYWORDS="~amd64"
134 PATCHES=(
135         "${FILESDIR}/${PN}-0.1.0-fix-openssl.patch"