sys-kernel/liquorix-sources: Bump to new version, drop old version.
[gentoo-zh.git] / sys-kernel / xanmod-hybrid / xanmod-hybrid-5.15.33.ebuild
blobfcf135bd8fbf55d801f4dc5dba3bf81da054f5b2
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI="8"
5 K_WANT_GENPATCHES="base extras"
6 K_GENPATCHES_VER="2"
7 K_SECURITY_UNSUPPORTED="1"
8 K_NOSETEXTRAVERSION="1"
9 ETYPE="sources"
10 inherit kernel-2
11 detect_version
13 DESCRIPTION="Full XanMod source, including the Gentoo patchset and other patch options."
14 HOMEPAGE="https://xanmod.org
15 https://github.com/zhmars/cjktty-patches"
16 LICENSE+=" CDDL"
17 KEYWORDS="~amd64"
18 IUSE="tt cjktty"
19 SLOT="stable"
20 XANMOD_VERSION="1"
21 XANMOD_URI="https://github.com/xanmod/linux/releases/download/"
22 OKV="${OKV}-xanmod"
23 CJKTTY_URI="https://raw.githubusercontent.com/zhmars/cjktty-patches/master/v${KV_MAJOR}.x/"
24 SRC_URI="
25 ${KERNEL_BASE_URI}/linux-${KV_MAJOR}.${KV_MINOR}.tar.xz
26 ${GENPATCHES_URI}
27 ${XANMOD_URI}/${OKV}${XANMOD_VERSION}/patch-${OKV}${XANMOD_VERSION}.xz
28 ${XANMOD_URI}/${OKV}${XANMOD_VERSION}-tt/patch-${OKV}${XANMOD_VERSION}-tt.xz
29 ${CJKTTY_URI}/cjktty-${KV_MAJOR}.${KV_MINOR}.patch
32 src_unpack() {
33 UNIPATCH_LIST_DEFAULT=""
34 UNIPATCH_LIST=""
36 if use tt ; then
37 UNIPATCH_LIST+=" ${DISTDIR}/patch-${OKV}${XANMOD_VERSION}-tt.xz"
38 else
39 UNIPATCH_LIST+=" ${DISTDIR}/patch-${OKV}${XANMOD_VERSION}.xz"
42 if use cjktty ; then
43 UNIPATCH_LIST+=" ${DISTDIR}/cjktty-${KV_MAJOR}.${KV_MINOR}.patch"
46 kernel-2_src_unpack
49 pkg_postinst() {
50 elog "MICROCODES"
51 elog "Use xanmod-sources with microcodes"
52 elog "Read https://wiki.gentoo.org/wiki/Intel_microcode"
55 pkg_postrm() {
56 kernel-2_pkg_postrm