app-backup/btrfs-assistant: add 2.1.1, drop 2.1
[gentoo-zh.git] / app-backup / btrfs-assistant / btrfs-assistant-2.1.1.ebuild
blob51c60ad1d65974869b8f9ae5fb4c9e464b5c55fb
1 #Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit xdg cmake optfeature
8 SRC_URI="https://gitlab.com/btrfs-assistant/btrfs-assistant/-/archive/${PV}/${P}.tar.bz2"
9 KEYWORDS="~amd64 ~x86"
11 DESCRIPTION="A GUI management tool to make managing a Btrfs filesystem easier."
12 HOMEPAGE="https://gitlab.com/btrfs-assistant/btrfs-assistant"
14 LICENSE="GPL-3"
15 SLOT="0"
17 DEPEND="
18         dev-qt/qtbase:6
19         dev-qt/qtsvg:6
21 BDEPEND="${DEPEND}"
22 RDEPEND="
23         media-fonts/noto
24         sys-auth/polkit
25         sys-fs/btrfs-progs
26         ${DEPEND}
29 pkg_postinst() {
30         xdg_pkg_postinst
31         optfeature "auto snapshot" app-backup/snapper
32         optfeature "auto balance and defrag" sys-fs/btrfsmaintenance