net-proxy/lantern-bin: version bump to 6.8.6 (#1217)
[gentoo-zh.git] / dev-libs / granite / granite-5.2.1.ebuild
blob90f395a942168586e203d5425f6fbb56660b94c4
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=6
6 VALA_MIN_API_VERSION=0.40
8 inherit cmake-utils gnome2-utils vala
10 DESCRIPTION="Elementary OS library that extends Gtk+"
11 HOMEPAGE="https://github.com/elementary/granite"
12 SRC_URI="https://github.com/elementary/granite/archive/${PV}.tar.gz -> ${P}.tar.gz"
14 LICENSE="LGPL-3"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm x86"
17 IUSE="demo nls test"
19 RDEPEND="
20 dev-libs/glib:2
21 dev-libs/libgee:0.8[introspection]
22 >=x11-libs/gtk+-3.22:3[introspection]
24 DEPEND="${RDEPEND}
25 >=dev-lang/vala-0.40.0
26 nls? ( sys-devel/gettext )
27 virtual/pkgconfig
30 src_prepare() {
32 # Disable building of the demo application (if needed)
33 use demo || cmake_comment_add_subdirectory demo
35 # Disable generation of the translations (if needed)
36 use nls || cmake_comment_add_subdirectory po
38 cmake-utils_src_prepare
39 vala_src_prepare
42 src_configure() {
43 local mycmakeargs=(
44 -DVALA_EXECUTABLE=${VALAC}
47 cmake-utils_src_configure
50 pkg_preinst() {
51 gnome2_icon_savelist
54 pkg_postinst() {
55 gnome2_icon_cache_update
58 pkg_postrm() {
59 gnome2_icon_cache_update