www-client/brave-bin: add 1.71.121, drop 1.71.118
[gentoo-zh.git] / dev-util / cargo-about / cargo-about-0.6.4.ebuild
blob632d344af72858c2469ba2201b9fbb6f3f66615d
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.3
6 EAPI=8
8 CRATES="
9 addr2line@0.22.0
10 adler@1.0.2
11 aho-corasick@1.1.3
12 anstream@0.6.15
13 anstyle-parse@0.2.5
14 anstyle-query@1.1.1
15 anstyle-wincon@3.0.4
16 anstyle@1.0.8
17 anyhow@1.0.86
18 askalono@0.4.6
19 assert_cmd@2.0.16
20 assert_fs@1.1.2
21 autocfg@1.3.0
22 backtrace@0.3.73
23 base64@0.22.1
24 bitflags@2.6.0
25 block-buffer@0.10.4
26 bstr@1.10.0
27 bumpalo@3.16.0
28 byteorder@1.5.0
29 bytes@1.7.1
30 camino@1.1.7
31 cargo-platform@0.1.8
32 cargo_metadata@0.18.1
33 cc@1.1.8
34 cd@0.3.0
35 cfg-expr@0.16.0
36 cfg-if@1.0.0
37 clap@4.5.15
38 clap_builder@4.5.15
39 clap_derive@4.5.13
40 clap_lex@0.7.2
41 codespan-reporting@0.11.1
42 codespan@0.11.1
43 colorchoice@1.0.2
44 cpufeatures@0.2.12
45 crc32fast@1.4.2
46 crossbeam-deque@0.8.5
47 crossbeam-epoch@0.9.18
48 crossbeam-utils@0.8.20
49 crypto-common@0.1.6
50 deranged@0.3.11
51 difflib@0.4.0
52 digest@0.10.7
53 doc-comment@0.3.3
54 either@1.13.0
55 equivalent@1.0.1
56 errno@0.3.9
57 fastrand@2.1.0
58 fern@0.6.2
59 fixedbitset@0.4.2
60 flate2@1.0.31
61 float-cmp@0.9.0
62 fnv@1.0.7
63 form_urlencoded@1.2.1
64 futures-channel@0.3.30
65 futures-core@0.3.30
66 futures-io@0.3.30
67 futures-sink@0.3.30
68 futures-task@0.3.30
69 futures-util@0.3.30
70 generic-array@0.14.7
71 getrandom@0.2.15
72 gimli@0.29.0
73 globset@0.4.14
74 globwalk@0.9.1
75 handlebars@6.0.0
76 hashbrown@0.14.5
77 heck@0.5.0
78 hermit-abi@0.3.9
79 home@0.5.9
80 http-body-util@0.1.2
81 http-body@1.0.1
82 http@1.1.0
83 httparse@1.9.4
84 hyper-rustls@0.27.2
85 hyper-util@0.1.7
86 hyper@1.4.1
87 idna@0.5.0
88 ignore@0.4.22
89 indexmap@2.3.0
90 ipnet@2.9.0
91 is_terminal_polyfill@1.70.1
92 itoa@1.0.11
93 jobserver@0.1.32
94 js-sys@0.3.69
95 krates@0.17.1
96 lazy_static@1.5.0
97 libc@0.2.155
98 libmimalloc-sys@0.1.39
99 linux-raw-sys@0.4.14
100 lock_api@0.4.12
101 log@0.4.22
102 memchr@2.7.4
103 mimalloc@0.1.43
104 mime@0.3.17
105 miniz_oxide@0.7.4
106 mio@1.0.1
107 normalize-line-endings@0.3.0
108 nu-ansi-term@0.50.1
109 num-conv@0.1.0
110 num-traits@0.2.19
111 object@0.36.3
112 once_cell@1.19.0
113 parking_lot@0.12.3
114 parking_lot_core@0.9.10
115 paste@1.0.15
116 percent-encoding@2.3.1
117 pest@2.7.11
118 pest_derive@2.7.11
119 pest_generator@2.7.11
120 pest_meta@2.7.11
121 petgraph@0.6.5
122 pin-project-internal@1.1.5
123 pin-project-lite@0.2.14
124 pin-project@1.1.5
125 pin-utils@0.1.0
126 pkg-config@0.3.30
127 powerfmt@0.2.0
128 ppv-lite86@0.2.20
129 predicates-core@1.0.8
130 predicates-tree@1.0.11
131 predicates@3.1.2
132 proc-macro2@1.0.86
133 quinn-proto@0.11.6
134 quinn-udp@0.5.4
135 quinn@0.11.3
136 quote@1.0.36
137 rand@0.8.5
138 rand_chacha@0.3.1
139 rand_core@0.6.4
140 rayon-core@1.12.1
141 rayon@1.10.0
142 redox_syscall@0.5.3
143 regex-automata@0.4.7
144 regex-syntax@0.8.4
145 regex@1.10.6
146 reqwest@0.12.5
147 ring@0.17.8
148 rmp-serde@0.14.4
149 rmp@0.8.14
150 rustc-demangle@0.1.24
151 rustc-hash@2.0.0
152 rustix@0.38.34
153 rustls-pemfile@2.1.3
154 rustls-pki-types@1.8.0
155 rustls-webpki@0.102.6
156 rustls@0.23.12
157 ryu@1.0.18
158 same-file@1.0.6
159 scopeguard@1.2.0
160 semver@1.0.23
161 serde@1.0.205
162 serde_derive@1.0.205
163 serde_json@1.0.122
164 serde_spanned@0.6.7
165 serde_urlencoded@0.7.1
166 sha2@0.10.8
167 slab@0.4.9
168 smallvec@1.13.2
169 socket2@0.5.7
170 spdx@0.10.6
171 spin@0.9.8
172 static_assertions@1.1.0
173 strsim@0.11.1
174 subtle@2.6.1
175 syn@2.0.72
176 sync_wrapper@1.0.1
177 tempfile@3.12.0
178 termcolor@1.4.1
179 termtree@0.4.1
180 thiserror-impl@1.0.63
181 thiserror@1.0.63
182 time-core@0.1.2
183 time@0.3.36
184 tinyvec@1.8.0
185 tinyvec_macros@0.1.1
186 tokio-rustls@0.26.0
187 tokio@1.39.2
188 toml@0.8.19
189 toml_datetime@0.6.8
190 toml_edit@0.22.20
191 tower-layer@0.3.2
192 tower-service@0.3.2
193 tower@0.4.13
194 tracing-core@0.1.32
195 tracing@0.1.40
196 try-lock@0.2.5
197 twox-hash@1.6.3
198 typenum@1.17.0
199 ucd-trie@0.1.6
200 unicode-bidi@0.3.15
201 unicode-ident@1.0.12
202 unicode-normalization@0.1.23
203 unicode-width@0.1.13
204 untrusted@0.9.0
205 url@2.5.2
206 utf8parse@0.2.2
207 version_check@0.9.5
208 wait-timeout@0.2.0
209 walkdir@2.5.0
210 want@0.3.1
211 wasi@0.11.0+wasi-snapshot-preview1
212 wasm-bindgen-backend@0.2.92
213 wasm-bindgen-futures@0.4.42
214 wasm-bindgen-macro-support@0.2.92
215 wasm-bindgen-macro@0.2.92
216 wasm-bindgen-shared@0.2.92
217 wasm-bindgen@0.2.92
218 web-sys@0.3.69
219 webpki-roots@0.26.3
220 winapi-util@0.1.9
221 windows-sys@0.48.0
222 windows-sys@0.52.0
223 windows-sys@0.59.0
224 windows-targets@0.48.5
225 windows-targets@0.52.6
226 windows_aarch64_gnullvm@0.48.5
227 windows_aarch64_gnullvm@0.52.6
228 windows_aarch64_msvc@0.48.5
229 windows_aarch64_msvc@0.52.6
230 windows_i686_gnu@0.48.5
231 windows_i686_gnu@0.52.6
232 windows_i686_gnullvm@0.52.6
233 windows_i686_msvc@0.48.5
234 windows_i686_msvc@0.52.6
235 windows_x86_64_gnu@0.48.5
236 windows_x86_64_gnu@0.52.6
237 windows_x86_64_gnullvm@0.48.5
238 windows_x86_64_gnullvm@0.52.6
239 windows_x86_64_msvc@0.48.5
240 windows_x86_64_msvc@0.52.6
241 winnow@0.6.18
242 winreg@0.52.0
243 zerocopy-derive@0.7.35
244 zerocopy@0.7.35
245 zeroize@1.8.1
246 zstd-safe@5.0.2+zstd.1.5.2
247 zstd-sys@2.0.13+zstd.1.5.6
248 zstd@0.11.2+zstd.1.5.2
249 ${PN}@${PV}
252 inherit cargo
254 DESCRIPTION="Cargo plugin to generate list of all licenses for a crate"
255 HOMEPAGE="https://github.com/EmbarkStudios/cargo-about"
256 SRC_URI="
257 ${CARGO_CRATE_URIS}
260 LICENSE="|| ( Apache-2.0 MIT )"
261 # Dependent crate licenses
262 LICENSE+=" Apache-2.0 BSD ISC MIT MPL-2.0 Unicode-DFS-2016"
263 SLOT="0"
264 KEYWORDS="~amd64"