1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 inherit desktop unpacker xdg
8 飞书整合即时消息、日历、音视频会议、云文档、工作台等功能于一体,成就团队和个人,更高效、更愉悦。 "
9 HOMEPAGE="https://www.feishu.cn/download"
11 amd64? ( Feishu-linux_x64-${PV}.deb )
12 arm64? ( Feishu-linux_arm64-${PV}.deb )
13 mips? ( Feishu-linux_mips64el-${PV}.deb )
20 KEYWORDS="~amd64 ~arm64 ~mips"
21 IUSE="big-endian abi_mips_n64"
22 REQUIRED_USE="mips? ( !big-endian abi_mips_n64 )"
24 RESTRICT="strip mirror bindist fetch"
27 app-misc/ca-certificates
36 einfo "Please download ${SRC_URI} at ${HOMEPAGE} "
37 einfo "and copy the .deb file into your distfiles directory"
38 einfo "default distfiles directory is: /var/cache/distfiles"
43 unpacker "${S}/usr/share/man/man1/bytedance-feishu-stable.1.gz"
44 unpacker "${S}/usr/share/doc/bytedance-feishu-stable/changelog.gz"
50 dosym -r /opt/bytedance/feishu/bytedance-feishu /usr/bin/bytedance-feishu-stable
51 domenu "${S}/usr/share/applications/bytedance-feishu.desktop"
52 doman "${S}/bytedance-feishu-stable.1"
53 dodoc "${S}/changelog"
55 for size in 16 24 32 48 64 128 256 ; do
56 newicon -s ${size} "${S}/opt/bytedance/feishu/product_logo_${size}.png" ${PN}.png
58 newicon -s scalable "${S}/opt/bytedance/feishu/product_logo_256.svg" ${PN}.svg
60 fperms +x "/opt/bytedance/feishu/bytedance-feishu"
61 fperms +x "/opt/bytedance/feishu/feishu"
62 fperms +x "/opt/bytedance/feishu/vulcan/vulcan"
63 fperms +x "/opt/bytedance/feishu/vulcan/vulcan_crashpad_handler"