net-dns/ddns-go: add 6.6.2, drop 6.6.1
[gentoo-zh.git] / dev-libs / libdatrie / libdatrie-0.2.13.ebuild
blobebeba550cf89d938a49855b7a182727c960b2dbf
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools
8 DESCRIPTION="Double-Array Trie Library"
9 HOMEPAGE="https://github.com/tlwg/libdatrie"
11 if [[ ${PV} == "9999" ]] ; then
12 inherit git-r3
13 EGIT_REPO_URI="https://github.com/tlwg/${PN}.git"
14 else
15 SRC_URI="https://github.com/tlwg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16 KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
19 LICENSE="LGPL-2.1"
20 SLOT="0"
22 BDEPEND="dev-vcs/git"
24 src_prepare() {
25 default
26 # Fixed version if in non git project
27 echo "${PV}" > VERSION
28 # From upstreams autogen.sh, to make it utilize the autotools eclass
29 # use eautoreconf from autotools.eclass instead of autogen.sh
30 eautoreconf