1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 MULTILIB_COMPAT
=( abi_mips_n32
)
9 DESCRIPTION
="A Rust port of shadowsocks"
10 HOMEPAGE
="https://github.com/shadowsocks/shadowsocks-rust"
13 amd64? ( https://github.com/shadowsocks/shadowsocks-rust/releases/download/v${PV}/shadowsocks-v${PV}.x86_64-unknown-linux-gnu.tar.xz )
14 arm? ( https://github.com/shadowsocks/shadowsocks-rust/releases/download/v${PV}/shadowsocks-v${PV}.arm-unknown-linux-gnueabi.tar.xz )
15 arm64? ( https://github.com/shadowsocks/shadowsocks-rust/releases/download/v${PV}/shadowsocks-v${PV}.aarch64-unknown-linux-gnu.tar.xz )
16 mips? ( https://github.com/shadowsocks/shadowsocks-rust/releases/download/v${PV}/shadowsocks-v${PV}.mipsel-unknown-linux-musl.tar.xz )
21 KEYWORDS
="-* ~amd64 ~arm ~arm64 ~mips" #mips not tested
24 REQUIRED_USE
="mips? ( !big-endian )"
29 usr/bin/ssmanager-rust
35 newbin
"${S}/sslocal" sslocal-rust
36 newbin
"${S}/ssmanager" ssmanager-rust
37 newbin
"${S}/ssserver" ssserver-rust
38 newbin
"${S}/ssurl" ssurl-rust
40 systemd_newunit
"${FILESDIR}/shadowsocks-rust_at.service" shadowsocks-rust@.service
41 systemd_newunit
"${FILESDIR}/shadowsocks-rust-server_at.service" shadowsocks-rust-server@.service
43 keepdir
/etc
/shadowsocks