app-editors/appflowy-bin: add 0.5.4, drop 0.5.3
[gentoo-zh.git] / app-crypt / cfssl / cfssl-1.6.5.ebuild
blob3d244721ab37eefc892e1a2f51f6734d3ed6c1bf
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit go-module
8 DESCRIPTION="Cloudflare's PKI and TLS toolkit"
9 HOMEPAGE="https://github.com/cloudflare/cfssl"
10 SRC_URI="https://github.com/cloudflare/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="Apache-2.0 BSD BSD-1 MIT MPL-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm64"
15 IUSE="hardened"
17 RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
19 PATCHES=(
20         "${FILESDIR}/${PN}-1.4.1-build-fix.patch"
23 src_compile() {
24         # bug 905997
25         use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
27         CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
30 src_install() {
31         dobin bin/*
32         dodoc CHANGELOG README.md