1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit meson optfeature
8 DESCRIPTION="SwayFX: Sway, but with eye candy!"
9 HOMEPAGE="https://github.com/WillPower3309/swayfx"
10 SRC_URI="https://github.com/WillPower3309/swayfx/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
15 IUSE="grimshot +man +swaybar +swaynag tray wallpapers X"
18 >=dev-libs/json-c-0.13:0=
19 >=dev-libs/libinput-1.21.0:0=
22 >=dev-libs/wayland-1.20.0
27 media-libs/mesa[gles2,libglvnd(+)]
28 swaybar? ( x11-libs/gdk-pixbuf:2 )
34 wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
35 X? ( x11-libs/libxcb:0= )
38 >=gui-libs/wlroots-0.16:=[X?]
39 <gui-libs/wlroots-0.17:=[X?]
42 x11-misc/xkeyboard-config
54 >=dev-libs/wayland-protocols-1.24
55 >=dev-build/meson-0.60.0
58 BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
59 REQUIRED_USE="tray? ( swaybar )"
62 eapply "${FILESDIR}/${P}-im.patch"
68 $(meson_feature man man-pages)
70 $(meson_feature X xwayland)
71 $(meson_feature swaybar gdk-pixbuf)
74 $(meson_use wallpapers default-wallpaper)
75 -Dfish-completions=true
76 -Dzsh-completions=true
77 -Dbash-completions=true
87 doman contrib/grimshot.1
88 dobin contrib/grimshot
93 optfeature_header "There are several packages that may be useful with swayfx:"
94 optfeature "wallpaper utility" gui-apps/swaybg
95 optfeature "idle management utility" gui-apps/swayidle
96 optfeature "simple screen locker" gui-apps/swaylock
97 optfeature "lightweight notification daemon" gui-apps/mako
99 einfo "For a list of additional addons and tools usable with sway please"
100 einfo "visit the offical wiki at:"
101 einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
102 einfo "Please note that some of them might not (yet) available on gentoo"