app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / app-editors / typora / typora-0.11.18.ebuild
blobcbf5a317d630c60fb613e24cb84506c5f432926b
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit desktop
8 DESCRIPTION="Typora will give you a seamless experience as both a reader and a writer."
9 HOMEPAGE="https://typora.io"
10 SRC_URI="https://hougearch.litterhougelangley.club/src/typora_${PV}_amd64.deb"
12 #TODO : update license
13 LICENSE="typora"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
18 RESTRICT="mirror"
20 DEPEND=""
21 RDEPEND="
22         x11-libs/libXScrnSaver
23         ${DEPEND}"
24 BDEPEND=""
26 QA_PREBUILT="*"
28 src_unpack() {
29         default
30         unpack "${WORKDIR}"/data.tar.xz
31         S="${WORKDIR}/usr"
34 src_install() {
35         local dir="/opt/${PN}"
37         insinto "${dir}"
38         rm -rf share/lintian
39         sed -i '/Change Log/d' share/applications/typora.desktop
40         doins -r bin share
42         fperms 0755 "${dir}/bin/typora"
43         fperms 4755 "${dir}/share/typora/chrome-sandbox"
44         dosym "../../opt/typora/bin/typora" "usr/bin/typora"
46         domenu share/applications/typora.desktop
49 pkg_postinst() {
50         update-desktop-database