app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / app-editors / typora / typora-1.5.8.ebuild
blob1f86b27dd6869c8d38573bca5a0b85f80b68ad45
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit unpacker xdg
8 DESCRIPTION="A truely minimal markdown editor."
9 HOMEPAGE="https://typora.io"
10 SRC_URI="https://download.typora.io/linux/typora_${PV}_amd64.deb"
12 LICENSE="typora"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE=""
17 RESTRICT="mirror splitdebug"
19 DEPEND=""
20 RDEPEND="
21         x11-libs/libXScrnSaver
22         net-print/cups
23         ${DEPEND}"
24 BDEPEND=""
26 QA_PREBUILT="*"
28 src_unpack() {
29         unpack_deb typora_${PV}_amd64.deb
30         S="${WORKDIR}"
33 src_install() {
34         mv "${S}/usr" "${D}" || die
36         pushd "${D}/usr/share/doc" > /dev/null || die
37         mv ${PN} ${P} || die
38         popd > /dev/null || die