app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / app-office / bytedance-feishu / bytedance-feishu-4.11.6.2.ebuild
blobdfc536e3ec49483d9d2b2d0112dfd1fb1966bcfd
1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MULTILIB_COMPAT=( abi_mips_n64 )
8 inherit desktop unpacker xdg
10 CDNVER="v5x9pa"
12 DESCRIPTION="feishu - ByteDance's enterprise collaboration platform"
13 HOMEPAGE="https://www.feishu.cn/"
14 SRC_URI="
15         amd64?  ( https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/${CDNVER}/${PN}-beta_4.11.6-2_amd64.deb )
16         arm64?  ( https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/${CDNVER}/${PN}-beta_4.11.6-2_arm64.deb )
17         mips?   ( https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/${CDNVER}/${PN}-beta_4.11.6-2_mips64el.deb )
20 LICENSE="bytedance-feishu"
21 SLOT="0"
22 KEYWORDS="-* ~amd64 ~arm64 ~mips"
23 IUSE="big-endian"
24 REQUIRED_USE="mips? ( !big-endian )"
26 RDEPEND="
27         dev-libs/nss
28         dev-util/desktop-file-utils
29         media-libs/alsa-lib
30         net-print/cups
31         x11-libs/gtk+:3
32         x11-libs/libX11
33         x11-libs/libXext
34         x11-libs/libxcb
35         x11-libs/libxkbcommon
36         x11-misc/xdg-utils
39 S="${WORKDIR}"
40 QA_PREBUILT="*"
42 src_prepare() {
43         eapply_user
44         sed -i 's/Application;//g' usr/share/applications/bytedance-feishu.desktop || die
45         rm -r usr/share/appdata || die
46         gzip -d "usr/share/man/man1/${PN}-beta.1.gz" || die
47         gzip -d "usr/share/doc/${PN}-beta/changelog.gz" || die
50 src_install() {
52         insinto "/"
53         doins -r "opt"
54         insinto "/usr/bin"
55         doins "usr/bin/bytedance-feishu-beta"
57         domenu "usr/share/applications/${PN}.desktop"
58         doman "usr/share/man/man1/${PN}-beta.1"
59         dodoc "usr/share/doc/${PN}-beta/changelog"
61         local size
62         for size in 16 24 32 48 64 128 256 ; do
63                 newicon -s ${size} "opt/bytedance/feishu/product_logo_${size}.png" ${PN}.png
64         done
66         fperms +x "/opt/bytedance/feishu/"{bytedance-feishu,lark}
67         fperms +x "/opt/bytedance/feishu/vulcan/vulcan"
71 pkg_postinst(){
72         xdg_pkg_postinst