app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / dev-libs / lunar-date / lunar-date-3.0.1.ebuild
blob869201ccf597a1de1e9937dcad23c3dc2b5d7255
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit meson
8 DESCRIPTION="Chinese Lunar Library"
9 HOMEPAGE="https://github.com/yetist/lunar-date"
10 SRC_URI="https://github.com/yetist/lunar-date/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="+dbus doc introspection test"
17 RDEPEND=">=dev-python/pygobject-2.11.5"
19 DEPEND="${RDEPEND}
20         dev-util/gdbus-codegen
21         sys-devel/gettext
22         virtual/pkgconfig
23         >=dev-util/intltool-0.35
24         doc? ( dev-util/gtk-doc )
25         introspection? ( dev-libs/gobject-introspection )
26         >=app-text/gnome-doc-utils-0.3.2"
28 DOCS="AUTHORS COPYING NEWS README.md"
30 src_configure(){
31         local emesonargs=(
32                 $(meson_use dbus service)
33                 $(meson_use doc docs)
34                 $(meson_use introspection introspection)
35                 $(meson_use test tests)
36         )
37         meson_src_configure