app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / dev-python / conda / conda-23.1.0.ebuild
blob114d82b7fe9ac128bb433c28527bfcfa1a304212
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{9..11} )
8 inherit distutils-r1
10 DESCRIPTION="OS-agnostic, system-level binary package manager and ecosystem"
11 HOMEPAGE="https://conda.io/"
12 SRC_URI="https://github.com/conda/conda/archive/${PV}.tar.gz -> ${P}.tar.gz"
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
18 DEPEND="dev-vcs/git
19                 dev-python/pyopenssl[${PYTHON_USEDEP}]
20                 dev-python/pluggy[${PYTHON_USEDEP}]
21                 dev-python/requests[${PYTHON_USEDEP}]
22                 dev-python/ruamel-yaml[${PYTHON_USEDEP}]
23                 dev-python/toolz[${PYTHON_USEDEP}]
24                 dev-python/tqdm[${PYTHON_USEDEP}]
25                 dev-python/conda-package-handling[${PYTHON_USEDEP}]
26                 dev-python/conda-package-streaming[${PYTHON_USEDEP}]
27                 dev-python/pycosat[${PYTHON_USEDEP}]"
28 RDEPEND="${DEPEND}"
29 BDEPEND=""
31 IUSE="+user"
33 distutils_enable_tests pytest
35 python_prepare_all() {
36         echo ${PV} > conda/.version || die
37         distutils-r1_python_prepare_all
40 python_install() {
41         distutils-r1_python_install
42         rm "${ED}/usr/bin/conda" || die
43         cp "${S}/conda/shell/bin/conda" "${ED}/usr/bin/conda" || die
44         # no need for Python Byte compiling and multi python slot, please do not use python_doscript
45         # this ebuild just use one stable python target
48 python_install_all() {
49         if use user ; then
50                 insinto /etc/conda
51                 doins "${FILESDIR}/condarc"
52         fi
55 pkg_postinst() {
56         elog "Initialize conda for shell interaction, "
57         elog "run 'conda init shells' "
58         elog "Currently compatible shells are {bash, fish, powershell, tcsh, xonsh, zsh}"
59         elog "base environment is managed by portage, do not use conda in base env!"