1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{9..11} )
10 DESCRIPTION="OS-agnostic, system-level binary package manager and ecosystem"
11 HOMEPAGE="https://conda.io/"
12 SRC_URI="https://github.com/conda/conda/archive/${PV}.tar.gz -> ${P}.tar.gz"
16 KEYWORDS="~amd64 ~x86"
19 dev-python/pyopenssl[${PYTHON_USEDEP}]
20 dev-python/pluggy[${PYTHON_USEDEP}]
21 dev-python/requests[${PYTHON_USEDEP}]
22 dev-python/ruamel-yaml[${PYTHON_USEDEP}]
23 dev-python/toolz[${PYTHON_USEDEP}]
24 dev-python/tqdm[${PYTHON_USEDEP}]
25 dev-python/conda-package-handling[${PYTHON_USEDEP}]
26 dev-python/conda-package-streaming[${PYTHON_USEDEP}]
27 dev-python/pycosat[${PYTHON_USEDEP}]"
33 distutils_enable_tests pytest
35 python_prepare_all() {
36 echo ${PV} > conda/.version || die
37 distutils-r1_python_prepare_all
41 distutils-r1_python_install
42 rm "${ED}/usr/bin/conda" || die
43 cp "${S}/conda/shell/bin/conda" "${ED}/usr/bin/conda" || die
44 # no need for Python Byte compiling and multi python slot, please do not use python_doscript
45 # this ebuild just use one stable python target
48 python_install_all() {
51 doins "${FILESDIR}/condarc"
56 elog "Initialize conda for shell interaction, "
57 elog "run 'conda init shells' "
58 elog "Currently compatible shells are {bash, fish, powershell, tcsh, xonsh, zsh}"
59 elog "base environment is managed by portage, do not use conda in base env!"