1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 DISTUTILS_USE_PEP517=setuptools
6 PYTHON_COMPAT=( python3_{9..11} pypy)
8 inherit distutils-r1 pypi
10 DESCRIPTION="netease cloud music support for feeluown"
11 HOMEPAGE="https://github.com/feeluown/feeluown-netease"
18 dev-python/marshmallow[${PYTHON_USEDEP}]
19 dev-python/requests[${PYTHON_USEDEP}]
20 dev-python/beautifulsoup4[${PYTHON_USEDEP}]
21 dev-python/pycryptodome[${PYTHON_USEDEP}]
22 media-libs/mutagen[${PYTHON_USEDEP}]
29 python_install_all() {
30 distutils-r1_python_install_all