app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / dev-python / fuo-ytmusic / fuo-ytmusic-0.3.1.ebuild
blob93033658d21095f20941cea3bf2a5f3ce9ed396f
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 PYTHON_COMPAT=( python3_{10..11} pypy)
6 DISTUTILS_USE_PEP517=poetry
8 inherit distutils-r1
10 DESCRIPTION="youtube music support for feeluown"
11 HOMEPAGE="https://github.com/feeluown/feeluown-ytmusic"
13 S="${WORKDIR}/feeluown-ytmusic-${PV}"
14 SRC_URI="https://github.com/feeluown/feeluown-ytmusic/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64"
20 RDEPEND="
21         dev-python/beautifulsoup4[${PYTHON_USEDEP}]
22         dev-python/pycryptodome[${PYTHON_USEDEP}]
23         dev-python/cachetools[${PYTHON_USEDEP}]
24         dev-python/ytmusicapi[${PYTHON_USEDEP}]
27 PDEPEND="
28         media-sound/feeluown
31 python_install_all() {
32         distutils-r1_python_install_all