1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 if [[ "${PV}" == 9999 ]]; then
10 EGIT_REPO_URI="${HOMEPAGE}"
13 SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/${PN}_${PV}.orig.tar.gz"
14 KEYWORDS="~amd64 ~x86"
17 DESCRIPTION="Libpurple (Pidgin) plugin for using a Telegram account"
18 HOMEPAGE="https://github.com/majn/telegram-purple"
22 IUSE="+gcrypt +png +webp"
27 gcrypt? ( dev-libs/libgcrypt )
28 !gcrypt? ( dev-libs/openssl )
29 png? ( media-libs/libpng )
30 webp? ( media-libs/libwebp )
38 $(use_with !gcrypt openssl)
39 $(use_enable png libpng)
40 $(use_enable webp libwebp)
42 econf "${myconf[@]}" || die "econf failed"
46 if [[ "${PV}" == 9999 ]]; then
47 elog "Note: this package is in an early (pre-alpha) stage, so if you"
48 elog "want to view changes, install this package often."
49 elog "More information is available in ${HOMEPAGE}"