app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / net-im / telegram-purple / telegram-purple-9999.ebuild
blobbb0cb2fa3fdce3a331fb9e43ee29d084a2db1884
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit eutils
8 if [[ "${PV}" == 9999 ]]; then
9         inherit git-r3
10         EGIT_REPO_URI="${HOMEPAGE}"
11         KEYWORDS=""
12 else
13         SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/${PN}_${PV}.orig.tar.gz"
14         KEYWORDS="~amd64 ~x86"
17 DESCRIPTION="Libpurple (Pidgin) plugin for using a Telegram account"
18 HOMEPAGE="https://github.com/majn/telegram-purple"
20 LICENSE="LGPL-3"
21 SLOT="0"
22 IUSE="+gcrypt +png +webp"
24 DEPEND="
25         net-im/pidgin
26         sys-libs/glibc
27         gcrypt? ( dev-libs/libgcrypt )
28         !gcrypt? ( dev-libs/openssl )
29         png? ( media-libs/libpng )
30         webp? ( media-libs/libwebp )
32 RDEPEND="${DEPEND}"
34 S=${WORKDIR}/${PN}
36 src_configure(){
37         local myconf=(
38                 $(use_with !gcrypt openssl)
39                 $(use_enable png libpng)
40                 $(use_enable webp libwebp)
41         )
42         econf "${myconf[@]}" || die "econf failed"
45 pkg_postinst() {
46         if [[ "${PV}" == 9999 ]]; then
47                 elog "Note: this package is in an early (pre-alpha) stage, so if you"
48                 elog "want to view changes, install this package often."
49                 elog "More information is available in ${HOMEPAGE}"
50         fi