app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / net-p2p / amule-dlp-antileech / amule-dlp-antileech-9999.ebuild
blob9630f293a42fe98af4c88552f223090926b8b014
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 WX_GTK_VER="3.0"
7 inherit autotools git-r3 wxwidgets
8 DESCRIPTION="$PN, dynamic DLP library for amule-dlp"
9 HOMEPAGE="https://github.com/persmule/amule-dlp.antileech"
10 EGIT_REPO_URI="https://github.com/persmule/amule-dlp.antiLeech.git"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="X"
17 DEPEND="x11-libs/wxGTK:${WX_GTK_VER}"
18 RDEPEND="net-p2p/amule-dlp[dynamic]"
20 src_prepare() {
21         default
22         eautoreconf || die
25 src_configure() {
26         if use X; then
27                 einfo "wxGTK with X / GTK support will be used"
28                 need-wxwidgets unicode
29         else
30                 einfo "wxGTK without X support will be used"
31                 need-wxwidgets base-unicode
32         fi
34         econf
37 src_install() {
38         emake DESTDIR="${D}" install || die