1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit linux-info go-module systemd
10 DESCRIPTION="A lightweight and high-performance transparent proxy solution based on eBPF"
11 HOMEPAGE="https://github.com/daeuniverse/dae"
15 KEYWORDS="~amd64 ~riscv"
18 https://github.com/daeuniverse/dae/releases/download/v${_MY_PV}/dae-full-src.zip -> ${P}.zip
23 app-alternatives/v2ray-geoip
24 app-alternatives/v2ray-geosite
28 BDEPEND="sys-devel/clang"
51 if kernel_is -lt ${MINKV//./ }; then
52 ewarn "Kernel version at least ${MINKV} required"
59 emake VERSION="${PV}" GOFLAGS="-buildvcs=false" CC=clang CFLAGS="$CFLAGS -fno-stack-protector"
64 systemd_dounit install/dae.service
66 newins example.dae config.dae.example
67 newins install/empty.dae config.dae
68 dosym -r "/usr/share/v2ray/geosite.dat" /usr/share/dae/geosite.dat
69 dosym -r "/usr/share/v2ray/geoip.dat" /usr/share/dae/geoip.dat