1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit git-r3 go-module systemd
8 DESCRIPTION="A Modern Dashboard For dae"
9 HOMEPAGE="https://github.com/daeuniverse/daed"
11 EGIT_REPO_URI="https://github.com/daeuniverse/daed.git"
19 app-alternatives/v2ray-geoip
20 app-alternatives/v2ray-geosite
24 webui? ( sys-apps/pnpm )
37 ego mod download -modcacherw
39 ego mod download -modcacherw
46 GO_ROOT="${S}" emake CC=clang CFLAGS="$CFLAGS -fno-stack-protector" APPNAME="${PN}" VERSION="${PV}"
50 local service=install/daed.service
53 systemd_dounit $service
56 sed -i "s!/usr/bin/daed!/usr/bin/dae-wing!" $service || die
57 systemd_newunit $service dae-wing.service
60 dosym -r "/usr/share/v2ray/geosite.dat" /usr/share/daed/geosite.dat
61 dosym -r "/usr/share/v2ray/geoip.dat" /usr/share/daed/geoip.dat