1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 EGIT_REPO_URI="https://github.com/aptly-dev/${PN}.git"
8 inherit bash-completion-r1 git-r3 go-module systemd
10 DESCRIPTION="A swiss army knife for Debian repository management"
11 HOMEPAGE="https://github.com/aptly-dev/aptly"
18 RESTRICT="test" # fails
20 RDEPEND="acct-user/aptly"
28 go build -o cmd/aptly -ldflags "-X main.Version=${PV}" || die "build failed"
32 go test -work ./... || die "test failed"
39 dobashcomp completion.d/aptly
40 insinto /usr/share/zsh/site-functions
41 doins completion.d/_aptly
42 systemd_dounit aptly-api.service
43 systemd_dounit aptly.service
44 newinitd "${FILESDIR}"/aptly.initd aptly
45 newconfd "${FILESDIR}"/aptly.confd aptly
46 newinitd "${FILESDIR}"/aptly-api.initd aptly-api
47 newconfd "${FILESDIR}"/aptly-api.confd aptly-api
49 diropts -o aptly -g aptly -m 0700
51 insopts -o aptly -g aptly -m 0644
53 doins "${FILESDIR}"/aptly.conf