app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / sys-apps / zypper / zypper-1.14.60.ebuild
blob89c14759d594b4d3531fa725a8e1645cc650bbf1
1 # Copyright 2017-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake
7 if [[ ${PV} == 9999* ]] ; then
8         inherit git-r3
9         EGIT_REPO_URI="https://github.com/openSUSE/zypper.git"
10         EGIT_CHECKOUT_DIR=${PN}-${PV}
11 else
12         SRC_URI="https://github.com/openSUSE/zypper/archive/refs/tags/${PV}.tar.gz -> zypper-${PV}.tar.gz"
13         KEYWORDS="~amd64 ~riscv"
14         S="${WORKDIR}/${PN}-${PV}"
17 DESCRIPTION="World's most powerful command line package manager"
18 HOMEPAGE="https://en.opensuse.org/Portal:Zypper"
19 LICENSE="GPL-2"
20 SLOT="0"
21 IUSE=""
22 RDEPEND="
23         sys-libs/libzypp
25 DEPEND="
26         app-admin/augeas
28 BDEPEND="${DEPEND}"
30 src_configure(){
31         mycmakeargs=(
32                 -DENABLE_BUILD_TRANS=ON
33                 -DENABLE_BUILD_TESTS=ON
34         )
35         cmake_src_configure