app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / www-servers / woof / woof-9999.ebuild
blob2fa4fcaf630a9560372305f8d99f9e543bbee66f
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_{9..11} )
8 inherit git-r3 python-single-r1
10 DESCRIPTION="an ad-hoc single file webserver"
11 HOMEPAGE="http://www.home.unix-ag.org/simon/woof.html https://github.com/simon-budig/woof"
12 EGIT_REPO_URI="https://github.com/simon-budig/${PN}.git"
13 EGIT_CLONE_TYPE="single"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
19 IUSE="+gzip +bzip2 +unzip"
21 DEPEND="
22         gzip? ( app-arch/gzip )
23         bzip2? ( app-arch/bzip2 )
24         unzip? ( app-arch/unzip )
27 RDEPEND="${DEPEND}"
28 BDEPEND=""
30 src_install(){
31         python_doscript ${PN}