app-crypt/etoken-sac: fix eutils EAPI 7
[gentoo-zh.git] / x11-wm / chamferwm / chamferwm-9999.ebuild
blob4a62022d4cb4eac972b528d75a28695473a487a2
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="A tiling X11 window manager with Vulkan compositor."
7 HOMEPAGE="https://github.com/jaelpark/chamferwm"
8 SRC_URI=""
10 EGIT_REPO_URI="https://github.com/jaelpark/chamferwm.git git://github.com/jaelpark/chamferwm.git"
12 inherit git-r3 meson
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE=""
19 DEPEND="
20         dev-libs/boost[python]
21         media-libs/shaderc
22         dev-util/vulkan-headers
23         media-libs/vulkan-loader
26 RDEPEND="
27         media-libs/vulkan-loader
28         dev-libs/boost[python]
31 BDEPEND=""
33 src_prepare(){
34         sed -i "s/python3')/python-3.7')/g" meson.build
37 src_install(){
38         into /usr
39         dobin "${BUILD_DIR}/chamfer"
41         insinto /usr/share/chamfer/shaders
43         doins "${BUILD_DIR}/default_fragment.spv"
44         doins "${BUILD_DIR}/default_geometry.spv"
45         doins "${BUILD_DIR}/default_vertex.spv"
46         doins "${BUILD_DIR}/frame_fragment.spv"
47         doins "${BUILD_DIR}/frame_geometry.spv"
48         doins "${BUILD_DIR}/frame_vertex.spv"
50         insinto /usr/share/applications/
52         doins "${S}/share/chamfer.desktop"