dev-util/binsider: new package
[gentoo-zh.git] / app-misc / rmtrash / rmtrash-1.15.ebuild
blobc805d34eed410deaf8f50086d2c4ca824ccefec0
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="trash-put made compatible to GNUs rm and rmdir"
7 HOMEPAGE="https://github.com/PhrozenByte/rmtrash"
8 SRC_URI="https://github.com/PhrozenByte/rmtrash/archive/v${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64"
14 RDEPEND="app-misc/trash-cli"
16 src_install() {
17         insinto /usr/bin
18         insopts -m755
19         doins rmtrash
20         doins rmdirtrash
23 pkg_postinst() {
24         elog "It is suggested to add following code into ~/.bashrc:"
25         elog "--------------------------------------------------------------------"
26         elog "          alias rm='rmtrash'"
27         elog "          alias rmdir='rmdirtrash'"
28         elog "          alias sudo='sudo '"
29         elog "--------------------------------------------------------------------"
30         elog "see https://github.com/PhrozenByte/rmtrash for more information"