dev-db/dbeaver-bin: bump version to 23.1.0
[gentoo-zh.git] / dev-db / dbeaver-bin / dbeaver-bin-23.1.0.ebuild
blob6a48e9c952b707fe37105e39037366786ee268dd
1 # Copyright 2019-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit desktop wrapper xdg
7 DESCRIPTION="Free universal database tool (community edition)."
8 HOMEPAGE="https://dbeaver.io/"
9 MY_PN="${PN%-bin*}-ce"
10 SRC_URI="amd64? ( https://dbeaver.io/files/${PV}/${MY_PN}-${PV}-linux.gtk.x86_64-nojdk.tar.gz -> ${P}-amd64.tar.gz )
11 arm64? ( https://dbeaver.io/files/${PV}/${MY_PN}-${PV}-linux.gtk.aarch64-nojdk.tar.gz -> ${P}-arm64.tar.gz )"
13 LICENSE="Apache-2.0 EPL-1.0 BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm64"
17 RDEPEND="dev-java/openjdk-bin:11"
18 DEPEND="${RDEPEND}"
20 MY_PN="${PN%-bin*}"
21 S="${WORKDIR}/${MY_PN}"
23 src_prepare() {
24 sed -e "s/^Icon=.*/Icon=${MY_PN}/" \
25 -e 's:/usr/share/dbeaver:/opt/dbeaver:g' \
26 -e '/^WMCLASS.*/d' \
27 -e "s:^Exec=.*:Exec=${EPREFIX}/usr/bin/${MY_PN}:" \
28 -i "${MY_PN}-ce.desktop" || die
29 default
32 src_install() {
33 doicon -s 128 "${MY_PN}.png"
34 newicon icon.xpm "${MY_PN}.xpm"
35 domenu "${MY_PN}-ce.desktop"
36 einstalldocs
37 rm "${MY_PN}-ce.desktop" "${MY_PN}.png" icon.xpm readme.txt || die
38 insinto "/opt/${MY_PN}-ce"
39 doins -r *
40 fperms 0755 "/opt/${MY_PN}-ce/${MY_PN}"
41 make_wrapper "${MY_PN}" "/opt/${MY_PN}-ce/${MY_PN}" "/opt/${MY_PN}-ce"
42 sed -e "s:^exec /opt/${MY_PN}-ce/${MY_PN}:exec /opt/${MY_PN}-ce/${MY_PN} -vm ${EPREFIX}/opt/openjdk-bin-11/bin:" \
43 -i "${D}/usr/bin/${MY_PN}" || die