net-proxy/mihomo-party-bin: add 1.5.10, drop 1.5.9
[gentoo-zh.git] / net-proxy / mihomo-party-bin / mihomo-party-bin-1.5.10.ebuild
blobbc0e2d6f56e7f5eedfa2fc8842cf2a736610429d
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop xdg-utils unpacker
8 DESCRIPTION="Mihomo Party"
9 HOMEPAGE="
10         https://mihomo.party
11         https://github.com/mihomo-party-org/mihomo-party
13 SRC_URI="https://github.com/mihomo-party-org/mihomo-party/releases/download/v${PV}/mihomo-party-linux-${PV}-amd64.deb"
15 S="${WORKDIR}"
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE="+tun"
21 DEPEND="
22         dev-libs/nss
23         media-libs/alsa-lib
24         media-libs/mesa
25         net-print/cups
26         x11-libs/gtk+:3
27         x11-libs/libdrm
28         x11-libs/libxkbcommon
31 RESTRICT="strip"
33 QA_PREBUILT="*"
35 src_install() {
36         domenu usr/share/applications/mihomo-party.desktop
37         doicon -s 512 usr/share/icons/hicolor/512x512/apps/mihomo-party.png
38         insinto /opt/
39         doins -r opt/mihomo-party
40         fperms +x /opt/mihomo-party/chrome-sandbox
41         fperms +x /opt/mihomo-party/chrome_crashpad_handler
42         fperms +x /opt/mihomo-party/mihomo-party
43         fperms +x /opt/mihomo-party/resources/sidecar/mihomo
44         fperms +x /opt/mihomo-party/resources/sidecar/mihomo-alpha
45         if use tun; then
46                 fperms +s /opt/mihomo-party/resources/sidecar/mihomo
47                 fperms +s /opt/mihomo-party/resources/sidecar/mihomo-alpha
48         fi
51 pkg_postinst() {
52         xdg_desktop_database_update
53         xdg_icon_cache_update
56 pkg_postrm() {
57         xdg_desktop_database_update
58         xdg_icon_cache_update