net-misc/hoppscotch-bin: make pkgcheck happy
[gentoo-zh.git] / app-office / anytype-bin / anytype-bin-0.35.4.ebuild
blobd73936fda4a414278083dbf24ab00c207b4ee648
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop xdg-utils
8 DESCRIPTION="A notebook based on p2p network"
9 HOMEPAGE="https://anytype.io"
10 SRC_URI="https://anytype-release.fra1.cdn.digitaloceanspaces.com/Anytype-${PV}.AppImage
11         https://anytype-release.fra1.cdn.digitaloceanspaces.com/anytype_${PV}_amd64.deb"
13 S="${WORKDIR}"
14 LICENSE="ASAL-1.0"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 RESTRICT="strip"
20 RDEPEND="sys-fs/fuse:0"
21 BDEPEND="app-arch/dpkg"
23 QA_PRESTRIPPED="*"
25 src_unpack() {
26         cp "${DISTDIR}/Anytype-$PV.AppImage" anytype-bin || die
29 src_prepare() {
30         default
31         dpkg -x "${DISTDIR}"/anytype_${PV}_amd64.deb . || die "dpkg icon extraction failed"
32         sed -i 's|Exec=/opt/Anytype/anytype %U|Exec=anytype-bin %U|g' usr/share/applications/anytype.desktop ||
33                 die "Sed Exec command failed"
36 src_install() {
37         dobin anytype-bin
38         doicon usr/share/icons/hicolor/0x0/apps/anytype.png || die "Icon installation failed"
39         domenu usr/share/applications/anytype.desktop || die "Desktop file installation failed"
42 pkg_postinst() {
43         xdg_desktop_database_update
46 pkg_postrm() {
47         xdg_desktop_database_update