app-i18n/libime-jyutping: add 1.0.12, drop 1.0.11
[gentoo-zh.git] / app-i18n / libime-jyutping / libime-jyutping-1.0.12.ebuild
blob4237fd46795b7390753c2f1e00ac297d48c9352c
1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake unpacker
8 DESCRIPTION="A library make use of libime to implement jyutping input method"
9 HOMEPAGE="https://github.com/fcitx/libime-jyutping"
10 SRC_URI="https://download.fcitx-im.org/fcitx5/${PN}/${P}_dict.tar.zst -> ${P}.tar.zst"
12 LICENSE="LGPL-2.1+ GPL-3+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc +engine test"
16 RESTRICT="!test? ( test )"
18 DEPEND="
19         >=app-i18n/libime-1.1.3:5
20         app-arch/zstd
21         >=dev-libs/boost-1.61:=
22         dev-libs/libfmt
23         doc? (
24                 app-text/doxygen
25                 dev-texlive/texlive-fontutils
26         )
27         engine? (
28                 app-i18n/fcitx:5
29                 app-i18n/fcitx-chinese-addons:5
30                 sys-devel/gettext
31         )
33 RDEPEND="${DEPEND}"
35 src_configure() {
36         local mycmakeargs=(
37                 -DENABLE_ENGINE=$(usex engine)
38                 -DENABLE_TEST=$(usex test)
39                 -DENABLE_DOC=$(usex doc)
40         )
41         cmake_src_configure
44 src_compile() {
45         cmake_src_compile
46         use doc && cmake_src_compile doc
49 src_install() {
50         cmake_src_install
51         use doc && dodoc -r "${BUILD_DIR}"/doc/*