get the right patch.
[gentoo-zh.git] / x11-terms / lilyterm / lilyterm-0.9.6.ebuild
blobe96888f896ab85f287fe82991652ed6a71c84c4c
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit fdo-mime
7 DESCRIPTION="A light and easy to use libvte based X Terminal Emulator"
8 HOMEPAGE="http://lilyterm.luna.com.tw/"
9 SRC_URI="http://lilyterm.luna.com.tw/${P}.tar.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14 IUSE=""
16 RDEPEND=">=dev-libs/glib-2.14
17 >=x11-libs/gtk+-2.10
18 >=x11-libs/vte-0.13"
20 DEPEND="${RDEPEND}
21 sys-devel/automake
22 sys-devel/autoconf
23 dev-util/pkgconfig
24 dev-util/intltool
25 sys-devel/gettext
26 dev-perl/XML-Parser"
28 src_compile() {
29 ./autogen.sh
30 econf
31 emake || die "emake failed."
34 src_install() {
35 emake DESTDIR="${D}" install || die "emake install failed."
36 dodoc AUTHORS ChangeLog TODO
39 pkg_postinst() {
40 fdo-mime_desktop_database_update
43 pkg_postrm() {
44 fdo-mime_desktop_database_update