dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / dev-cpp / fbthrift / fbthrift-2024.11.04.00-r1.ebuild
blobbb6463a848ef3dfb72231b62f2693d03aed0c883
1 # Copyright 2022-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 # These must be bumped together:
7 # dev-cpp/edencommon
8 # dev-cpp/fb303
9 # dev-cpp/fbthrift
10 # dev-cpp/fizz
11 # dev-cpp/folly
12 # dev-cpp/mvfst
13 # dev-cpp/wangle
14 # dev-util/watchman
16 inherit cmake
18 DESCRIPTION="Facebook's branch of Apache Thrift (C++ bindings)"
19 HOMEPAGE="https://github.com/facebook/fbthrift"
20 SRC_URI="https://github.com/facebook/fbthrift/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
22 LICENSE="Apache-2.0"
23 SLOT="0/${PV}"
24 KEYWORDS="~amd64 ~arm64"
25 IUSE="test"
27 # See https://github.com/facebook/fbthrift/issues/628
28 RESTRICT="test"
30 DEPEND="
31         app-arch/zstd:=
32         ~dev-cpp/fizz-${PV}:=
33         ~dev-cpp/folly-${PV}:=
34         dev-cpp/gflags:=
35         dev-cpp/glog:=[gflags]
36         ~dev-cpp/mvfst-${PV}:=
37         ~dev-cpp/wangle-${PV}:=
38         dev-libs/boost:=[nls(+)]
39         dev-libs/libevent:=
40         dev-libs/libfmt:=
41         dev-libs/openssl:=
42         dev-libs/xxhash:=
43         sys-libs/zlib:=
45 RDEPEND="
46         ${DEPEND}
47         test? ( dev-cpp/gtest )
50 src_configure() {
51         local mycmakeargs=(
52                 -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
53                 -DLIB_INSTALL_DIR="$(get_libdir)"
54                 -Denable_tests=$(usex test 'ON' 'OFF')
55                 -Wno-dev
56         )
57         cmake_src_configure