1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 PYTHON_COMPAT=( python3_{10..13} )
6 inherit gnome.org meson-multilib python-any-r1
8 DESCRIPTION="C++ interface for glib2"
9 HOMEPAGE="https://www.gtkmm.org https://gitlab.gnome.org/GNOME/glibmm"
13 KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
14 IUSE="gtk-doc debug test"
15 RESTRICT="!test? ( test )"
18 >=dev-libs/glib-2.77.0:2[${MULTILIB_USEDEP}]
19 dev-libs/libsigc++:3[gtk-doc?,${MULTILIB_USEDEP}]
32 PATCHES=( "${FILESDIR}"/${P}-libcxx-fix.patch )
37 # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
38 sed -i -e '/giomm_tls_client/d' tests/meson.build || die
41 sed -i -e "/^subdir('tests')/d" meson.build || die
45 multilib_src_configure() {
48 -Dbuild-deprecated-api=true
49 $(meson_native_use_bool gtk-doc build-documentation)
50 $(meson_use debug debug-refcounting)
51 -Dbuild-examples=false