1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION="MessagePack for C++"
9 HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
10 SRC_URI="https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/${P}.tar.gz"
14 KEYWORDS="amd64 ~arm arm64 ~riscv x86 ~amd64-linux ~x86-linux ~x64-macos"
15 IUSE="+boost doc examples test"
17 REQUIRED_USE="test? ( boost )"
19 RESTRICT="!test? ( test )"
21 RDEPEND="boost? ( dev-libs/boost[context] )
22 !<dev-libs/msgpack-5.0.0"
24 BDEPEND="doc? ( app-text/doxygen[dot] )
25 test? ( sys-libs/zlib )"
29 -DMSGPACK_BUILD_EXAMPLES=OFF
31 -DMSGPACK_BUILD_TESTS="$(usex test)"
32 -DMSGPACK_USE_BOOST="$(usex boost)"
33 -DMSGPACK_USE_X3_PARSE="$(usex boost)"
49 local HTML_DOCS=( "${BUILD_DIR}"/doc_cpp/html/. )
55 docompress -x /usr/share/doc/${PF}/examples