dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / dev-cpp / rapidfuzz-cpp / rapidfuzz-cpp-3.2.0.ebuild
blobbaef94a1dc311895451635595d534b4809d629b6
1 # Copyright 2022-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake
8 DESCRIPTION="Rapid fuzzy string matching in C++"
9 HOMEPAGE="https://github.com/rapidfuzz/rapidfuzz-cpp/"
10 SRC_URI="
11         https://github.com/rapidfuzz/rapidfuzz-cpp/archive/v${PV}.tar.gz
12                 -> ${P}.gh.tar.gz
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
21 BDEPEND="
22         test? (
23                 >=dev-cpp/catch-3
24         )
27 src_configure() {
28         local mycmakeargs=(
29                 -DRAPIDFUZZ_BUILD_TESTING=$(usex test)
30         )
31         cmake_src_configure