dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / dev-cpp / robin-hood-hashing / robin-hood-hashing-3.11.5-r2.ebuild
blobaf33088be0d75e2bd7622410b49d9433e7f57e7c
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit cmake
8 DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
9 HOMEPAGE="https://github.com/martinus/robin-hood-hashing"
10 SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv x86"
16 PATCHES=( "${FILESDIR}/${PN}-include-cstdint.patch" )
18 src_configure() {
19         local mycmakeargs=(
20                 -DRH_STANDALONE_PROJECT=OFF
21                 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/share/"
22         )
23         cmake_src_configure