1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 USE_RUBY="ruby31 ruby32 ruby33"
8 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
9 RUBY_FAKEGEM_TASK_DOC="yard"
11 RUBY_FAKEGEM_DOCDIR="doc"
12 RUBY_FAKEGEM_EXTRADOC="README.md"
14 RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
18 DESCRIPTION="A generic swappable back-end for XML parsing"
19 HOMEPAGE="https://www.rubydoc.info/gems/multi_xml"
20 SRC_URI="https://github.com/sferik/multi_xml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
24 KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
27 ruby_add_bdepend "doc? ( dev-ruby/yard )"
28 ruby_add_bdepend "test? ( dev-ruby/ox )"
31 eapply "${FILESDIR}/${P}-ox24.patch"
33 sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die
34 sed -e '/bundler/I s:^:#:' \
35 -e '/yardstick/,/end/ s:^:#:' \
36 -e '/rubocop/I s:^:#:' \
41 CI=true each_fakegem_test