dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / dev-ruby / pkg-config / pkg-config-1.5.6.ebuild
blob6c481b9f844ac63ff27f316d6c607cd5aa1fe2eb
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 USE_RUBY="ruby31 ruby32 ruby33"
7 RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
9 inherit ruby-fakegem
11 DESCRIPTION="A pkg-config implementation by Ruby"
12 HOMEPAGE="https://github.com/ruby-gnome/pkg-config"
13 LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
15 KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~s390 sparc x86"
16 SLOT="0"
17 IUSE="test"
19 ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
20 # this is used for testing
21 DEPEND+=" test? ( x11-libs/cairo )"
23 all_ruby_prepare() {
24         sed -e '/test_cflags/aomit "Fragile on Gentoo"' -i test/test-pkg-config.rb || die
27 each_ruby_test() {
28         ruby-ng_testrb-2 -Ilib test/test-pkg-config.rb || die