1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 USE_RUBY="ruby31 ruby32 ruby33"
7 RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
11 DESCRIPTION="A pkg-config implementation by Ruby"
12 HOMEPAGE="https://github.com/ruby-gnome/pkg-config"
13 LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
15 KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~s390 sparc x86"
19 ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
20 # this is used for testing
21 DEPEND+=" test? ( x11-libs/cairo )"
24 sed -e '/test_cflags/aomit "Fragile on Gentoo"' -i test/test-pkg-config.rb || die
28 ruby-ng_testrb-2 -Ilib test/test-pkg-config.rb || die