1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 USE_RUBY="ruby31 ruby32 ruby33"
8 RUBY_FAKEGEM_TASK_TEST="test spec"
9 RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc History.rdoc README.rdoc"
11 RUBY_FAKEGEM_NAME="net-ldap"
13 RUBY_FAKEGEM_GEMSPEC="net-ldap.gemspec"
17 DESCRIPTION="Pure ruby LDAP client implementation"
18 HOMEPAGE="https://github.com/ruby-ldap/ruby-net-ldap"
19 SRC_URI="https://github.com/ruby-ldap/ruby-net-ldap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
22 KEYWORDS="~amd64 ~x86"
25 ruby_add_bdepend "test? ( >=dev-ruby/flexmock-1.3.0 )"
28 sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
32 ${RUBY} -Ilib:test:. -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die