1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit cmake optfeature prefix xdg
8 DESCRIPTION="Open source reimplementation of Jazz Jackrabbit 2"
9 HOMEPAGE="https://deat.tk/jazz2/"
10 SRC_URI="https://github.com/deathkiller/jazz2-native/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
11 S="${WORKDIR}/${PN}-native-${PV}"
25 !sdl? ( media-libs/glfw )
26 sdl? ( media-libs/libsdl2 )
31 "${FILESDIR}"/${PN}-system-source.patch
36 hprefixify Sources/Shared/Environment.cpp
38 # We need to install README.md to a different directory, default
39 # src_install will handle that.
40 sed -i '/README_INSTALL_DESTINATION/d' cmake/ncine_installation.cmake || die
45 -DNCINE_LINUX_PACKAGE="${PN}"
47 -DNCINE_DOWNLOAD_DEPENDENCIES=OFF
48 -DNCINE_LINKTIME_OPTIMIZATION=OFF
49 -DNCINE_STRIP_BINARIES=OFF
50 -DNCINE_VERSION_FROM_GIT=OFF
51 -DNCINE_WITH_BACKWARD=OFF
55 -DNCINE_PREFERRED_BACKEND=$(usex sdl SDL2 GLFW)
57 -DNCINE_WITH_AUDIO=$(usex openal)
64 optfeature "game data unless you want to install it manually" ${CATEGORY}/${PN}-data