1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 PYTHON_COMPAT=( python3_{10..12} )
7 inherit desktop python-single-r1 toolchain-funcs
9 MY_COMMIT="73c5fe86fd831dec45a22077e8d63dd2b6a6349e"
11 DESCRIPTION="Funny multiplayer game about cute little fluffy bunnies"
12 HOMEPAGE="https://libregames.gitlab.io/jumpnbump"
13 SRC_URI="https://gitlab.com/LibreGames/jumpnbump/-/archive/${MY_COMMIT}/${P}.tar.bz2"
14 S=${WORKDIR}/${PN}-${MY_COMMIT}
18 KEYWORDS="~amd64 ~x86"
20 REQUIRED_USE="gui? ( ${PYTHON_REQUIRED_USE} )"
24 media-libs/libsdl2[joystick,sound,video]
25 media-libs/sdl2-mixer[mod]
33 $(python_gen_cond_dep '
34 dev-python/pillow[${PYTHON_USEDEP}]
35 dev-python/pygobject[${PYTHON_USEDEP}]
37 x11-libs/gdk-pixbuf:2[introspection]
38 x11-libs/gtk+:3[introspection]
40 BDEPEND="gui? ( ${PYTHON_DEPS} )"
43 "${FILESDIR}"/${PN}-1.61-ranlib.patch
47 use gui && python-single-r1_pkg_setup
51 tc-export AR CC RANLIB
53 emake PREFIX="${EPREFIX}"/usr
56 emake PREFIX="${EPREFIX}"/usr jnbmenu
57 python_fix_shebang menu/jumpnbump_menu.py
62 emake PREFIX="${ED}"/usr install
64 use gui && emake -C menu PREFIX="${ED}"/usr install
67 rm -- "${ED}"/usr/share/icons/${PN}.png || die