1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop wrapper
8 DESCRIPTION="Dystopian Document Thriller"
9 HOMEPAGE="https://papersplea.se"
10 SRC_URI="papers-please_${PV}_i386.tar.gz"
13 LICENSE="PAPERS-PLEASE"
15 KEYWORDS="~amd64 ~x86"
16 RESTRICT="fetch bindist"
18 QA_PREBUILT="opt/${PN}/*"
22 >=x11-libs/libX11-1.6.2[abi_x86_32]
23 >=x11-libs/libXau-1.0.7-r1[abi_x86_32]
24 >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32]
25 >=x11-libs/libXext-1.3.2[abi_x86_32]
26 >=x11-libs/libXxf86vm-1.1.3[abi_x86_32]
27 >=x11-libs/libdrm-2.4.46[abi_x86_32]
28 >=x11-libs/libxcb-1.9.1[abi_x86_32]
29 >=virtual/opengl-7.0-r1[abi_x86_32]
44 einfo "Please buy & download ${SRC_URI} from:"
46 einfo "and move it to your DISTDIR directory."
53 rm -v launch.sh LICENSE || die
54 mv README "${T}"/README || die
62 fperms +x ${dir}/PapersPlease
64 make_wrapper ${PN} "./PapersPlease" "${dir}" "${dir}"
65 make_desktop_entry ${PN} "Papers, Please"