1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 LUA_COMPAT=( lua5-1 luajit )
8 inherit cmake lua-single
10 DESCRIPTION="A graphical user interface to create and modify quests for the Solarus engine"
11 HOMEPAGE="https://www.solarus-games.org"
13 if [[ ${PV} == 9999 ]]; then
14 EGIT_REPO_URI="https://gitlab.com/solarus-games/solarus-quest-editor.git"
18 SRC_URI="https://gitlab.com/solarus-games/solarus-quest-editor/-/archive/v${PV}/solarus-quest-editor-v${PV}.tar.gz"
20 S="${WORKDIR}/solarus-quest-editor-v${PV}"
26 REQUIRED_USE="${LUA_REQUIRED_USE}"
28 # Upstream (and their CMake) claim that all of these are required deps
36 >=media-libs/libsdl2-2.0.1[X,joystick,video]
39 media-libs/sdl2-image[png]
40 >=media-libs/sdl2-ttf-2.0.12
45 ~games-engines/solarus-${PV}
49 "${FILESDIR}/${P}-fix-segfault.patch"
53 local mycmakeargs=( -DSOLARUS_USE_LUAJIT="$(usex lua_single_target_luajit)" )