dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / games-misc / solarus-quest-editor / solarus-quest-editor-9999.ebuild
blobed25f0c0943862be9fef621d6bd83f7a3aab51f4
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 LUA_COMPAT=( lua5-1 luajit )
8 inherit cmake lua-single
10 DESCRIPTION="A graphical user interface to create and modify quests for the Solarus engine"
11 HOMEPAGE="https://www.solarus-games.org"
13 if [[ ${PV} == 9999 ]]; then
14         EGIT_REPO_URI="https://gitlab.com/solarus-games/solarus-quest-editor.git"
15         EGIT_BRANCH="dev"
16         inherit git-r3
17 else
18         SRC_URI="https://gitlab.com/solarus-games/solarus-quest-editor/-/archive/v${PV}/solarus-quest-editor-v${PV}.tar.gz"
19         KEYWORDS="~amd64"
20         S="${WORKDIR}/solarus-quest-editor-v${PV}"
23 LICENSE="GPL-3+"
24 SLOT="0"
26 REQUIRED_USE="${LUA_REQUIRED_USE}"
28 # Upstream (and their CMake) claim that all of these are required deps
29 RDEPEND="
30         ${LUA_DEPS}
31         dev-games/physfs
32         dev-qt/qtcore:5
33         dev-qt/qtgui:5
34         dev-qt/qtwidgets:5
35         media-libs/libmodplug
36         >=media-libs/libsdl2-2.0.1[X,joystick,video]
37         media-libs/libvorbis
38         media-libs/openal
39         media-libs/sdl2-image[png]
40         >=media-libs/sdl2-ttf-2.0.12
43 DEPEND="
44         ${RDEPEND}
45         ~games-engines/solarus-${PV}
48 PATCHES=(
49         "${FILESDIR}/${P}-fix-segfault.patch"
52 src_configure() {
53         local mycmakeargs=( -DSOLARUS_USE_LUAJIT="$(usex lua_single_target_luajit)" )
54         cmake_src_configure