dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / games-misc / sound-of-sorting / sound-of-sorting-0.6.6_pre20221012.ebuild
blob68fc3317b14148e1fcd63b147fbd6edc183d6526
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 WX_GTK_VER="3.2-gtk3"
7 inherit desktop wxwidgets xdg
9 DESCRIPTION="Visualization and Audibilization of Sorting Algorithms"
10 HOMEPAGE="https://panthema.net/2013/sound-of-sorting/ https://github.com/bingmann/sound-of-sorting"
11 #SRC_URI="http://panthema.net/2013/sound-of-sorting/${P}.tar.bz2"
12 COMMIT="5cfcaf752593c8cbcf52555dd22745599a7d8b1b"
13 SRC_URI="https://github.com/bingmann/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz
14         https://dev.gentoo.org/~pacho/${PN}/${PN}_512.png"
15 S="${WORKDIR}/${PN}-${COMMIT}"
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="~amd64"
21 RDEPEND="
22         media-libs/libsdl
23         x11-libs/wxGTK:${WX_GTK_VER}
25 DEPEND="${RDEPEND}"
27 src_configure() {
28         setup-wxwidgets unicode
29         default
32 src_install() {
33         default
34         make_desktop_entry ${PN} "Sound of Sorting"
35         newicon -s 512 "${DISTDIR}/${PN}_512.png" ${PN}.png