1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit readme.gentoo-r1 toolchain-funcs xdg
8 DESCRIPTION="Turn-based strategy game heavily inspired by the classic Panzer General"
9 HOMEPAGE="https://lgames.sourceforge.io/LGeneral/"
11 https://downloads.sourceforge.net/lgeneral/${P}.tar.gz
12 https://downloads.sourceforge.net/lgeneral/kukgen-data-1.1.tar.gz"
14 LICENSE="GPL-2+ CC-BY-SA-3.0"
16 KEYWORDS="~amd64 ~x86"
19 media-libs/libsdl[sound,video]
23 BDEPEND="sys-devel/gettext"
26 "${FILESDIR}"/${PN}-1.4.3-fix-utf8.patch
30 emake AR="$(tc-getAR)"
36 keepdir /usr/share/${PN}/{ai_modules,music,terrain}
38 # Install the free kukgen WW1 campaign
39 cd ../${PN}-data-* || die
41 dodoc docs/README.kukgen
42 newdoc docs/MANUAL MANUAL.kukgen
44 insinto /usr/share/${PN}
45 doins -r {campaigns,gfx,maps,nations,scenarios,sounds,units}
47 local DISABLE_AUTOFORMATTING=yes
49 "Only the free kukgen WWI campaign has been installed.
51 If you wish to play the Panzer General (PG) WWII campaign, you need
52 to convert the original CD-ROM game data by (for example) running:
54 SDL_VIDEODRIVER=dummy \\
55 lgc-pg -s /path/to/cdrom/DAT -d ${EPREFIX}/usr/share/${PN}
57 See ${EPREFIX}/usr/share/doc/${PF}/README.lgc-pg* for details."
58 readme.gentoo_create_doc
64 # README is redundant with what `make install` says but ensures visibility
65 readme.gentoo_print_elog